Support email address not receiving emails.

Incident Report for Device Magic

Resolved

This incident has been resolved.
Posted Jun 26, 2024 - 09:26 EDT

Investigating

Contacting the Support Team via email at support@devicemagic.com is currently unavailable. To reach the support team please log into your Device Magic account and click on the 'Chat' icon located in the lower right corner of every page.

Thank you for your patience and understanding as the team investigates the issue.
Posted Jun 26, 2024 - 08:53 EDT
This incident affected: Device Magic Systems.