System Maintenance

Incident Report for Device Magic

Resolved

The scheduled maintenance has been completed.
Posted Apr 20, 2025 - 08:39 EDT

Monitoring

Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 20, 2025 - 08:03 EDT

Investigating

We will be performing system maintenance on 4/20/2025 from 8:00am EDT - 9:00am EDT.

No service interruptions are expected during this time.

We appreciate your patience and understanding.
As always, if you have questions or issues please submit them to support@devicemagic.com
Posted Apr 17, 2025 - 11:18 EDT
This incident affected: Device Magic Systems.