Submission Delivery Delay
Incident Report for Device Magic
Resolved
This incident has been resolved.
Posted May 16, 2023 - 13:25 EDT
Update
We are continuing to monitor for any further issues.
Posted May 16, 2023 - 13:24 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 16, 2023 - 12:45 EDT
Investigating
We are currently experiencing longer than usual submission delivery times. We are investigating the issue and will provide an update when there is one available.
Posted May 16, 2023 - 11:59 EDT
This incident affected: Submission Deliveries, Submission Resending, and Dispatches.