Submission Resending Delays
Incident Report for Device Magic
Resolved
This incident has been resolved.
Posted Apr 25, 2023 - 16:06 EDT
Monitoring
An issue was discovered that is affecting the timeliness of submission resend deliveries. A fix has been implemented and we are monitoring closely. The backlog of resent submissions will work through on it's own as quickly as possible.
Posted Apr 25, 2023 - 14:47 EDT
This incident affected: Submission Resending.