Degraded API Calls

Incident Report for Device Magic

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 29, 2025 - 11:41 EDT

Investigating

We're experiencing high load on the platform, as a result loading web stores and api calls to the dm database or related submission api calls are degraded.
Posted Mar 28, 2025 - 16:57 EDT
This incident affects: Forms Website.