Mobile Device Loading Delays
Incident Report for Device Magic
Resolved
This incident has been resolved.
Posted Aug 23, 2023 - 10:44 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 23, 2023 - 09:38 EDT
Identified
The issue has been identified and a fix is being implemented
Posted Aug 23, 2023 - 09:16 EDT
Investigating
We are currently experiencing a delay in communication with mobile devices. This affects loading of forms, sending submissions, loading dispatches, and loading resources. The team is working as quickly as possible to identify the issue.

We apologize for any inconvenience and appreciate your patience.
Posted Aug 23, 2023 - 08:36 EDT
This incident affected: Submission Deliveries, Dispatches, and Device Magic Systems.