Submission Delivery/Resending Delay
Incident Report for Device Magic
Resolved
This incident has been resolved.
Posted Jul 18, 2023 - 15:47 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 18, 2023 - 15:25 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 18, 2023 - 15:00 EDT
Investigating
We are currently experiencing longer than usual submission delivery/resending times. We are investigating the issue and will provide an update when there is one available.
Posted Jul 18, 2023 - 14:44 EDT
This incident affected: Submission Deliveries, Submission Resending, and Dispatches.