Submission Resending Delays
Incident Report for Device Magic
Resolved
This incident has been resolved.
Posted May 18, 2023 - 13:28 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 18, 2023 - 12:58 EDT
Investigating
We are currently experiencing an issue with Submission Resends being delayed. We are investigating the cause and will provide an update as soon as one is available.
Posted May 18, 2023 - 12:30 EDT
This incident affected: Submission Resending.