Submissions Processing Delays

Incident Report for Device Magic

Resolved

This incident has been resolved.
Posted Jul 02, 2026 - 07:09 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 01, 2026 - 19:11 EDT

Investigating

We are currently experiencing an unusually high volume of deliveries, which is resulting in longer processing times than normal. As a result, some submissions may take additional time to appear as received or fully processed in your account.

Our team is actively working to process all deliveries as quickly and safely as possible, and we will restore normal processing times once volumes return to expected levels. Thank you for your patience.
Posted Jul 01, 2026 - 15:01 EDT
This incident affected: Submission Deliveries.