Dropbox Destination Delivery Issue

Incident Report for Device Magic

Resolved

This incident has been resolved.
Posted Feb 12, 2025 - 15:09 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 12, 2025 - 11:53 EST

Investigating

We are currently experiencing an issue where Dropbox Destination deliveries are failing to complete, causing delivery errors. Our engineering team is actively investigating and working on a fix. Thank you for your patience.
Posted Feb 12, 2025 - 08:27 EST
This incident affected: Submission Deliveries.