Page Loading Delays
Incident Report for Device Magic
Resolved
This incident has been resolved.
Posted Nov 07, 2024 - 16:44 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 06, 2024 - 21:20 EST
Investigating
We are currently aware of an issue causing slower-than-normal page loading times for some users. Our team is investigating the cause and working to resolve it as quickly as possible. We apologize for any inconvenience and appreciate your patience. Please stay tuned for updates.

This delay is NOT affecting the mobile app or submission deliveries.
Posted Oct 31, 2024 - 12:28 EDT
This incident affected: Forms Website.