Undelivered Submissions / Unknown Delivery Error
Incident Report for Device Magic
Resolved
This incident has been resolved.
Posted Sep 15, 2023 - 17:01 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 15, 2023 - 16:17 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 15, 2023 - 15:46 EDT
Investigating
We are currently investigating an issue in which a small portion of our customers are seeing 'Undelivered Submissions' and a 'Delivery Issue' that has very limited information.

The team is currently working to identify what is causing the issue. These deliveries will resolve themselves over time, and there is no threat of any data loss.

We appreciate your understanding and patience.
Posted Sep 15, 2023 - 12:06 EDT
This incident affected: Submission Deliveries.