System Delays
Incident Report for Device Magic
Resolved
Delivery times have returned to normal.
Posted Sep 05, 2024 - 18:05 EDT
Monitoring
Due to higher than normal volume the system is experiencing delays in deliveries. The team has added more horsepower to the system to work through the backlog as quickly as possible.

We apologize for any inconvenience this may cause and thank you for your patience.
Posted Sep 05, 2024 - 14:47 EDT
This incident affected: Submission Deliveries, Submission Resending, and Dispatches.